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• I have been using the Mac platform since 1986, and
began using Macs during English and Journalism
courses at Northern Kentucky University. I have
never owned a PC.

•  Certified Support Professional macOS Sonoma

•  Certified Associate - Mac Integration macOS 14

• I provide on-site support and training in the Naples,
Florida area.

• I assist both residential and business clients.

About Your Instructor

Jeff Bohr 
jeff@jeffbohr.com  

239.595.0482
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Jeff Bohr 
jeff@jeffbohr.com  

239.595.0482

• Review macOS history 

• Check System and Hardware requirements 

• Review Apple’s Feature list 

• Review usage of new features

Agenda
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A Little Mac History: Naming OS Versions
Versions of macOS have had both public and 
private internal code names since OS X was 
released as a beta version for $29.95 on 
September 13, 2000. This makes it easier than 
saying “I am running macOS 10.13.2.” They 
started naming the operating system (OS) with 
names of big cats until 2013, when they switched 
to names of locations in Apple’s home state of 
California, likely because they were running out 
of large members of the feline species. 

The first Mac OS X Public Beta was internally 
code named “Kodiak.”

macOS Sonoma
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Naming OS Versions

	 •	 OS X 10.0: Cheetah 
	 •	 OS X 10.1: Puma 
	 •	 OS X 10.2: Jaguar 
	 •	 OS X 10.3 Panther (Pinot) 
	 •	 OS X 10.4 Tiger (Merlot) 
	 •	 OS X 10.4.4 Tiger (Intel: Chardonay) 
	 •	 OS X 10.5 Leopard (Chablis) 
 	 •	 OS X 10.6 Snow Leopard 
	 •     OS X 10.7 Lion  
       •    	OS X 10.8 Mountain Lion (Zinfandel) 

March 24, 2001 
September 25, 2001 
August 24, 2002 
October 24, 2003 
April 29, 2005 
April 29, 2005 
October 26, 2007 
August 28, 2009 
July 20, 2011 
July 25, 2012 

Version                                                                                                                Release Date
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Naming OS Versions

• OS X 10.9 Mavericks (Cabernet) 
• OS X 10.10: Yosemite (Syrah) 
• OS X 10.11: El Capitan (Gala) 
• macOS 10.12: Sierra (Fuji) 
• macOS 10.13: High Sierra (Lobo) 
• macOS 10.14 Mojave 
• macOS 10.15 Catalina 
• macOS 11 Big Sur 
• macOS Monterey 
• macOS Ventura 

October 22, 2013  
October 16, 2014 
September 30, 2015 
September 20, 2016 
September 25, 2017 
September  24, 2018 
October 7, 2019 
November 12, 2020 
October 25, 2021 
October 24, 2022 

Version                                                                                                                Release Date
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• macOS Sonoma September 26, 2023

Version                                                                                                                Release Date

Naming OS Versions



macOS Sonoma Introduction
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macOS Sonoma (version 14) is the latest major release of macOS, Apple's 
operating system for Macintosh computers. The successor to macOS 

Ventura, it was announced at WWDC 2023 on June 5, 2023, and released 
on September 26, 2023. It is named after the wine region located in 

California's Sonoma County. 
The first developer beta was released on June 5, 2023, and macOS Sonoma 

entered public beta on July 11, 2023.

https://en.wikipedia.org/wiki/Software_versioning
https://en.wikipedia.org/wiki/MacOS
https://en.wikipedia.org/wiki/Apple_Inc.
https://en.wikipedia.org/wiki/Operating_system
https://en.wikipedia.org/wiki/Macintosh
https://en.wikipedia.org/wiki/MacOS_Ventura
https://en.wikipedia.org/wiki/MacOS_Ventura
https://en.wikipedia.org/wiki/WWDC_2023
https://en.wikipedia.org/wiki/Sonoma_County_wine
https://en.wikipedia.org/wiki/County_of_Sonoma,_California
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Hardware Requirements



Hardware Requirements: Specific Hardware List
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MacBook Pro 
• MacBook Pro (16-inch, 2023) 
• MacBook Pro (14-inch, 2023) 
• MacBook Pro (13-inch, M2, 2022) 
• MacBook Pro (16-inch, 2021) 
• MacBook Pro (14-inch, 2021) 
• MacBook Pro (13-inch, M1, 2020) 
• MacBook Pro (13-inch, 2020, Two Thunderbolt 3 ports) 
• MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports) 
• MacBook Pro (16-inch, 2019) 
• MacBook Pro (13-inch, 2019, Two Thunderbolt 3 ports) 
• MacBook Pro (15-inch, 2019) 
• MacBook Pro (13-inch, 2019, Four Thunderbolt 3 ports) 
• MacBook Pro (15-inch, 2018) 
• MacBook Pro (13-inch, 2018, Four Thunderbolt 3 ports) 
MacBook Air 
• MacBook Air (15-inch, M2, 2023) 
• MacBook Air (M2, 2022) 
• MacBook Air (M1, 2020) 
• MacBook Air (Retina, 13-inch, 2020) 
• MacBook Air (Retina, 13-inch, 2019) 
• MacBook Air (Retina, 13-inch, 2018)

iMac 
• iMac (24-inch, M1, 2021) 
• iMac (Retina 5K, 27-inch, 2020) 
• iMac (Retina 5K, 27-inch, 2019) 
• iMac (Retina 4K, 21.5-inch, 2019) 
iMac Pro 
• iMac Pro (2017) 
Mac mini 
• Mac mini (2023) 
• Mac mini (M1, 2020) 
• Mac mini (2018) 
Mac Studio 
• Mac Studio (2023) 
• Mac Studio (2022) 
Mac Pro 
• Mac Pro (2023) 
• Mac Pro (2019) 
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Downloading macOS Sonoma

Go to System Preferences > General > Software Update to find macOS Sonoma. Click 
Upgrade Now and follow the onscreen instructions. 



• Homescreen Widgets/Interactive 
widgets are now available on Mac 

• Easier Screen Sharing  
• Enhanced Video Effects 
• More Privacy in Safari 
• More With Messages 
• Game Mode 
• Communication Safety Features 
• New Aerial Screen Savers 
• An Improved Typing Experience 
• Accessibility Features 
• Upgrades to the Notes App 
• Game Mode 
• Safari Profiles 
• Videoconferencing 
• AirPods Features 

• Autofill Security Codes 
• Sync shared passwords across your 

family 
• Get a mini crossword every day

Features
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Widgets on your Mac!
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Widgets on your Mac!
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macOS Sonoma finally addresses the ongoing widget problem plaguing Apple computers for 
the past several years. Gone are the days of having to open Notification Center to see 
important information like weather, battery details for your connected Apple devices, and 
more. Now, you can see all that data directly on your desktop thanks to some really well-
crafted widgets. 

These widgets are almost exactly like those on iOS 17. To get started, you just right-click (or 
control-click) on the desktop, select Add Widgets, then select the ones you want. The first 
widget determines where the rest of the widgets are set up. Of course, widget quality 
depends on the app you’re using, too, so keep that in mind. 

Ultimately, these widgets make it easy to keep up with important information directly on 
your Mac’s desktop. That’s made even better with the ability to tap on the desktop to clear 
all windows, which offers a clean way to check in on things before heading back to work. 
While it might be easy to clutter up the smaller display of the 13-inch MacBook Air, the 15-
inch MacBook Air and larger screens seem to leave plenty of room to set up multiple widgets 
without getting in the way of anything. 



Widgets on your Mac!
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When not in use, interactive desktop widgets fade into the background by taking on a 
monochrome style, allowing you to concentrate on the active app or window. 

If you prefer this look, you can make it permanent by going to System Settings -> Desktop & 
Dock. In the "Widgets" section, set Widget Style to Monochrome 



System Settings Navigation

2024 CLASSES
macOS Sonoma

In macOS Ventura, Apple replaced 
System Preferences with System 
Settings to align it with iOS and 
iPadOS, but the way controls were 
organized left many users wanting. 

The same System Settings 
interface remains in ‌macOS 
Sonoma‌, but it is now easier to 
navigate through different menu 
screens you have visited without 
continually scrolling through the 
sidebar, thanks to the addition of 
backward and forward buttons. 



Better Screen Sharing
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Screen Sharing is its own app in ‌macOS Sonoma‌. It's located in 
Applications/Utilities, and includes a list of all computers you've 
connected to in the past, the ability to see all computers on your 
local network with screen sharing enabled, and the option to create 
groups of computers. 

It also features a high performance mode when a screen sharing 
connection has been established. Click the info (i) button next to a 
connection, and change the Screen Sharing Type from Standard to 
High Performance. High performance mode allows you to use the 
native resolution of the host computer's display, reduces latency, 
improves image quality, and features HDR and multi-monitor 
support. The feature is available on Macs with Apple silicon running 
‌macOS Sonoma‌ or later. 



Better Screen Sharing
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Use High Performance screen sharing 
High Performance screen sharing allows for advanced color workflows and improved 
responsiveness. 

High Performance screen sharing supports stereo audio, HDR video reference mode, 
4:4:4 chroma subsampling, and high frame rates (30 or 60 fps). 

Turn on High Performance screen sharing 
When controlling or observing using a supported Apple Silicon Mac and client Mac, you 
can enable High Performance screen sharing. 
• In Remote Desktop ,       select a computer list in the sidebar of the main window, 
select a computer, then choose Interact > Control or Interact > Observe. 
If the computer supports High Performance screen sharing, you see the Select Screen 
Sharing Type pane and can choose High Performance.

• To edit the chosen Screen Sharing Type later, select the computer, choose File > Get 
Info, Control & Observe, then select the desired Screen Sharing Type at the bottom.

https://support.apple.com/HT210435


FaceTime Reactions
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FaceTime Reactions
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FaceTime Reactions
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Presenter Overlay
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When you're in a ‌FaceTime‌ or Zoom call, click-hold the green traffic light 
in the corner of an open app window and you'll see a screen sharing 
option, while a new Presenter Overlay feature can be used to keep you 
on screen and better able to point to details. 

When on a video call, you can either place yourself inside a movable 
bubble in the corner of the window or desktop that you're sharing, or 
you can bring on-screen content into the background of your own 
environment so that it looks as if you're standing just in front of it. 



Presenter Overlay
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Presenter Overlay
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Presenter Overlay
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Presenter Overlay
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Apple has made a laundry list of changes, additions and improvements to its Safari 
web browser. Everything from privacy and security to the way you can access sites has 
been updated.  

On a code level, things have been updated to make Safari faster than ever, but there 
are plenty of new features and option to explore too. It's now possible to add web apps 
to the Dock so you can treat any website like an app, for example. Use the Add To 
Dock option and you can Command + Tab your way between apps and sites, and enjoy 
the benefit of an improved notification experience. 

From a security point of view, there is now the ability to share passkeys and iCloud 
keychain passwords. There have also been various privacy enhancements such as the 
automatic removal of URL trackers in Private Browsing. On top of this, Private 
Browsing also now offer even more privacy by locking windows when they are not 
being used.

More New Safari Features
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Safari has gained a new feature called Profiles, which is designed to help keep your 
browsing separate for different use cases like Work, School, or Personal. 

Go to the Profiles section in Safari -> Settings..., and you can create custom profiles, 
choose a symbol and color for each one, and select a Favorites folder. 

Profiles silo your history, Tab Groups, and cookies, and you can also assign specific 
extensions to different profiles to optimize your browsing experience based on the 
task at hand.

More New Safari Features
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More New Safari Features
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Communication Safety Features
Communication Safety is an opt-in feature that warns 
children when sending or receiving photos that contain 
nudity. It's enabled by default for children under the age of 
13 who are signed in with an Apple ID and part of a Family 
Sharing group, but parents can also enable it for older 
teens as well. 

When the feature is enabled in System Settings -> Screen 
Time -> Communication Safety, photos and videos 
containing nudity are automatically blurred in supported 
apps including Messages and ‌FaceTime‌, and the child will 
be warned about viewing sensitive content. The warning 
also provides children with ways to get help. It uses on-
device processing to detect photos and videos containing 
nudity, ensuring that Apple and third parties cannot access 
the content, and that end-to-end encryption is preserved 
in the Messages app.
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Undo Sent Email
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After sending the email, an Undo Send option will appear at the bottom of the 
sidebar (if you don't have the sidebar showing, select View -> Show Sidebar in 
the menu bar). By default, you have 10 seconds to click it before the option 
disappears, after which the message cannot be unsent, but the interval can also 
be set to 20 or 30 seconds or turned off entirely for immediate sending



Undo Sent Email
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Thanks to a new option in Safari, you can 
now create standalone web apps and add 
them to your Dock, alongside your regular 
apps. 

All you have to do is visit a website in Safari 
and select File -> Add to Dock.... You can 
then give the web app a name and even 
change its icon. When you open a docked 
web app, it will open in its own separate 
window that includes back and forward 
buttons for simple navigation.

Safari: Dock Web Apps
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Apple News+ Now 
contains Puzzles! 
If you want to 
challenger 
yourself, Open 
News+ and give it 
a try, they have a 
full crossword and 
mini crossword to 
test your mental 
skills!

Get a mini crossword every day
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Another function of Continuity Camera is the ability to use a nearby ‌iPhone ‌ as the 
microphone input for your Mac. As long as the ‌iPhone ‌ is running iOS 16 or later and signed 
into the same Apple ID, you can speak into it and the audio will be seamlessly delivered to 
your Mac, sans video. 

The following steps show you how to set it up in macOS Sonoma. 

	 1. On your Mac, click the Apple () symbol in the menu bar and select System Settings…. 

	 2. Click Sound in the sidebar. 

	 3. Under "Output & Input," click the Input tab. 

	 4. Select the name of your nearby ‌iPhone ‌, listed as Type "Continuity Camera."

Use Nearby iPhone as Microphone Input
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Use Nearby iPhone as Microphone Input

2024 CLASSES
macOS Sonoma

When using Phone as microphone, 
you  can control sound mode via 
menu bar panel.



Show/Hide Desktop
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By default, ‌macOS Sonoma ‌ hides all windows when you click on your 
wallpaper. This is handy if you tend to have a bunch of files on the 
screen that you need access to. But if you find this behavior 
maddening, you can limit it to happen only when Stage Manager is 
enabled. 

Go to System Settings -> Desktop & Dock. In the Desktop & ‌Stage 
Manager‌ section, look for the option Click wallpaper to reveal desktop, 
then click Always and choose Only in ‌Stage Manager‌ instead.



• macOS Sonoma ‌ supports simultaneous use of keyboard input and Dictation, without 
any disruption in your flow of thought. 

• In other words, you can keep typing after hitting the Dictation shortcut (assignable in 
System Settings -> Keyboard). So whenever your fingers need a rest, you can 
complete the sentence you were just typing by saying it out loud

Seamless Keyboard Input and Dictation
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Text Prediction

Thanks to improved machine learning 
technology, Apple has made macOS a lot 
more helpful, because it can better 
predict what you're going to type next. 
Apple says it has adopted a "transformer 
language model" that can even 
personalize prediction for individual users, 
learning your personal preferences and 
word choices to be more useful when 
typing. 

As you type, the predicted text appears 
ahead of the cursor. If it has accurately 
predicted what you want to type, press 
the spacebar and macOS will fill it in for 
you. After using ‌‌‌macOS Sonoma ‌‌‌ for a few 
weeks, you should notice that the 
suggestions are much better at predicting 
what you want to say and presenting 
words for you to autofill. 
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Text Prediction
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If you find all of this 
distracting, you can 
turn it off. Go to 
System Settings -> 
Keyboard. Next to 
Input Sources, click 
Edit…. In the next 
window, toggle off 
the switch next to 
Show inline 
predictive text. 



When you drag PDFs into Notes, 
they are now presented full-width 
in the note, making it easier to 
view and interact with them. 

Notes is no longer restricted to 
rendering the first page of a PDF. 
You can now view the individual 
pages of a document you're 
reviewing right inside the note, 
which is really handy for 
previewing multiple PDFs in the 
same note. You also get a row of 
thumbnails across the top of the 
PDF that you can click to navigate 
to a specific page more quickly.

Managing PDFs in Notes
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Apple has made its stock Notes app 
significantly more useful by adding the 
simple yet powerful ability to link notes 
and connect related notes together. With 
just a few clicks, you can create links 
between notes in ‌‌macOS Sonoma ‌, making 
it easy to jump from one idea to another. 

One way of adding a new link is by right-
clicking on a space, word or phrase in any 
note and selecting Add Link from the 
contextual menu. You can also use the 
Command-K shortcut. This will let you link 
to another note by typing in its title. Using 
the "Name" field, you can create an 
optional alternative title for the link, or just 
stick with the original title for clarity. Once 
you're done, the link appears as hyperlink-
style underlined text in your note, and 
clicking it snaps you straight into the note 
you linked to.

 Link Notes Together
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 Link Notes Together
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The Notes app also offers an additional, quicker way to add links: Typing two greater-than 
symbols (>>) into a note invokes a list containing your six most recently modified notes, 
and tapping one instantly adds a link to that note. 

The same feature can be found in iOS, meaning you can now create wiki-style collections 
of interlinked notes, allowing you to organize your thoughts or discover new connections 
and associations between ideas.

Link From a List of Notes
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Studio Light and Background Blur, Choose Center Stage Camera
Studio Light is now available in macOS when using video conferencing apps, on Studio 
Display and Mac models with Apple silicon, without the need for Continuity Camera. In 
the ‌FaceTime‌ menu bar UI, you can darken the background and illuminate your face using 
the Studio Light intensity slider. 

With the Portrait slider, you can also control the amount of background blur, adding more 
or less blur to the depth-of-field effect. 

In ‌macOS Sonoma ‌, Continuity Camera automatically detects your face and frames you in 
the center, without you having to enable Center Stage. Still, turning on Center Stage 
keeps you centered in the camera frame as you move around. 

Choose Center Stage from the Video menu in the menu bar. To switch between the rear 
cameras on your ‌iPhone ‌, click the arrow next to Center Stage, then choose Main or Ultra 
Wide. 
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Caps Lock Is On
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If the Caps Lock key on your keyboard is enabled in ‌macOS Sonoma ‌, a handy 
indicator appears right near the cursor, so you're less likely to TYPE LIKE THIS BY 
ACCIDENT and get your passwords wrong. 

Apple has also made the text cursor a little thicker, and its color now changes 
relative to the active application, so you'll have a better idea of which window 
your text is going to appear in when you start typing. 



You can now send notes from the Notes 
app directly to Pages. Simply open the 
note, click the Share button, then choose 
Open in Pages from the share sheet. 

From there you can continue to edit the 
note in Pages, then save it or export it as a 
PDF, Word file, EPUB, and more.

 Open Notes in Pages
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Find Messages Faster
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Previously in macOS, you could type a word or phrase in the search field of 
Apple's Messages app and it would return matching results, but there was no 
way to filter messages to more easily find what you were looking for. 

That's changed in ‌‌macOS Sonoma ‌‌, and now you can combine multiple filters. 
If you're looking for images from a certain person, for example, you can type 
in "photos" and then the person's name, clicking each search filter to narrow 
down your search results.



Safari can remove tracking parameters 
from URLs in order to prevent cross-
website tracking. When a tracking 
parameter is detected while browsing 
or copying a link, Safari strips the 
identifying components of the URL, 
while leaving the rest intact. The links 
still work as expected, but no longer 
have unique identifiers. 

To enable the feature for all browsing, 
open Safari -> Settings..., click the 
Advanced tab, make sure the box is 
checked next to Use advanced tracking 
and fingerprint protection, then choose 
"in all browsing" in the dropdown.

Remove All URL Tracking
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In Safari 17, if you have the Favorites Bar enabled (View -> 
Show Favorites Bar in Safari's menu bar) the favicon for 
each site will appear beside its title, allowing you to more 
easily spot it in the bar. 

Favicons can certainly be handy, but they can make your 
browser interface look too busy and cluttered. Another 
possible issue with the space they take up is that if you have 
a full row of websites in your Favorites Bar, some of them 
will be lopped off the viewable area, and you may have to 
click the double chevron icon at the far right to reveal them. 

If this happens in your case, don't worry. It's not obvious, 
but you can easily prevent favicons from appearing in the 
Favorites Bar. Simply right-click anywhere on the bar and 
uncheck Show Icons in the pop-up menu.

Safari Favicons
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Automatically Close Safari Tabs
macOS can now close Safari's browser tabs on your behalf, based on when you last 
viewed them. Select Safari -> Settings... in the menu bar, then click the Tabs section. 

Next to "Automatically close tabs" you'll find options to make the browser auto-close 
tabs that have not been viewed After One Day, After One Week, or After One Month. 
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• Staying in Safari Settings, the Passwords 
menu now has a Share Passwords with 
Family option. This allows you to create a 
group of trusted contacts that you can 
share passwords and passkeys with 
across devices. (Passkeys let users sign 
in to apps and sites the same way they 
unlock their devices: With a fingerprint, 
a face scan, or a screen lock PIN.) 

• Using the new feature, passwords and 
passkeys for shared media accounts, 
utilities, bills, and more can be provided 
to multiple people, and each person in 
the group can access, add to, and 
change passwords that are shared.

Share Passwords With Family

2024 CLASSES
macOS Sonoma



Clean Up Verification Codes
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These days, many websites and 
services use one-time passcodes 
sent via SMS or over email for 
verification purposes, but these 
one-time codes can soon clog up 
your Mail inbox and Messages 
app. 

In ‌macOS Sonoma ‌, there's a new 
option to have those messages 
auto-delete after the code is 
autofilled and used to 
authenticate a login. Go to Safari 
-> Settings... and click the 
Password option menu. Toggle on 
“Clean Up Automatically.



In Safari, you can set different search engines for normal and Private Browsing modes. For 
example, you may want to set Google as the default search engine in regular browsing mode 
and a different search engine such as DuckDuckGo in Private Browsing mode for privacy 
reasons. 

Go to Safari -> Settings..., click the Search section, then select a browser from the Private 
Browsing search engine dropdown.

Set Private Browsing Search Engine
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What is Ecosia? Ecosia uses the ad revenue from your searches to plant 
trees where they are needed the most. By searching with Ecosia, you're 
not only reforesting our planet, but you're also empowering the 
communities around our planting projects to build a better future for 
themselves. Give it a try!

Set Private Browsing Search Engine
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Ecosia uses the Bing 
search engine



Private Browsing Authentication
If you have any Private Browsing tabs open in Safari and then leave your computer, 
Apple's browser now requires Touch ID authentication or your Mac password to access 
them again. 

If you don't tend to leave your Mac unlocked or find the authentication requirement 
annoying, you can turn it off pretty easily: Go to Safari -> Settings..., click the Privacy 
section, then uncheck the box next to Require ‌Touch ID‌ to view locked tabs 
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In Safari, third-party app extensions have gained per-website privacy settings where 
relevant, allowing you to control access for all extensions with access to user data. 

You can find the "Edit websites..." for each app extension in the Extensions section of Safari's 
Settings window.

Per-Website App Extension Settings
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Per-Website App Extension Settings
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Disable Pointer Acceleration
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Gamers rejoice – you can now disable pointer acceleration in ‌macOS Sonoma ‌. By 
default in macOS, the pointer moves more quickly for fast mouse movements and more 
precisely for slow mouse movements. Previously there was no way to prevent this 
natively, but that's changed. 

Go to System Settings -> Mouse -> Advanced..., then toggle off the switch next to 
Pointer acceleration. 



When recording an audio message in Messages, you're now able to pause and then 
continue recording the same message before sending. 

Additionally, when listening to audio messages you received, a long click on the play 
button lets you opt to play back at up to 2x speed. Received audio messages are 
automatically transcribed, too.

Audio Message Improvements
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Block Quote formatting 
makes it easy to visually 
offset a section of writing 
with a quote bar, while 
Monospaced formatting has 
been updated to Monostyled, 
for inset text with a distinct 
background. 

You can find these in the 
Notes menu bar under 
Format, or by clicking the text 
style icon when a note is 
open. 

Notes Formatting Additions
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Easier Autocorrect Editing
Autocorrection now briefly 
underlines autocorrected 
words, and you can right-click 
an underlined word to reveal 
and choose the original word 
that you typed. 

macOS will also learn your 
typing habits over time for each 
app, and avoid corrections that 
you revert. This also applies to 
explicit language, which will be 
added to your personal 
vocabulary list.
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Using the new Live Speech accessibility 
feature, you can type on your Mac and 
have your words spoken aloud, or 
directly into apps like ‌‌FaceTime‌‌ audio. 
Live Speech can be set up in ‌macOS 
Sonoma‌ by going to Settings -> 
Accessibility -> Live Speech, where you 
can choose a voice to use, and save 
commonly used phrases. 

Alternatively, you can record yourself 
reading and make a Personal Voice for 
use with Live Speech. Go to System 
Settings -> Accessibility -> Personal 
Voice, then tap Create a Personal Voice.

Live Speech

2024 CLASSES
macOS Sonoma



Game Mode
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Activate Game Mode
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Game Mode gives games the highest priority access to your CPU and GPU, lowering 
usage for background tasks. It turns on automatically when you fullscreen any game via 
the green button in the top-left corner of the game's window. When you enter full 
screen in this way, a Game Mode menu appears in the menu bar. You can use this menu 
to confirm that Game Mode is turned on for your game. 

Game Mode also turns off automatically when you stop viewing your game in full screen. 
You can also turn it off while your game is still in full screen mode: From the Game Mode 
menu in the menu bar, choose Turn Game Mode Off



You can now share 
photos and videos stored 
in iCloud Photos by 
generating an iCloud 
link. 

Simply select a photo or 
drag a selection box over 
several photos, click the 
Share button, then select 
Copy ‌iCloud‌ Link, and it 
will be copied to your 
clipboard ready for 
pasting in an email or 
message. 

Copy iCloud Link
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Sonoma brings all the Apple TV 
screensavers to your Mac - they 
download on demand to save on 
storage, and they look great. The way 
to get the best out of them though, is 
to use the same video for your 
wallpaper and screensaver. You can 
do this using the Show as screen 
saver / wallpaper toggle in System 
Settings -> Wallpaper, and Screen 
Saver. 

With the toggle enabled, your icons 
and app windows fade out and the 
desktop wallpaper starts to move 
when the screen saver comes on.

Wallpaper to Screen Saver
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Sonoma lets you toggle system 
settings like Bluetooth, Wi-Fi, Dark 
Mode, Focus Modes, and more directly 
in Spotlight search. 

You can still access these settings in 
Control Center and the System 
Settings app, but some users will find 
this method a little quicker. It's the 
same small yet welcome quality of life 
improvement that users have seen in 
iOS 17 on ‌iPhone ‌.

System Settings in Spotlight
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iCloud Passwords Extension
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Apple's ‌iCloud‌ password manager can now be used in Chrome for Mac, Microsoft Edge, 
and other Chromium-based browsers, thanks to an updated ‌iCloud‌ Passwords extension 
that works in ‌macOS Sonoma ‌. 

In other words, you don't need to open Safari or migrate your ‌iCloud‌ passwords to 
another password manager. The Chrome extension can also AutoFill passwords and one-
time codes, save new passwords, and lets you right-click QR codes to set up code 
generators

I don’t use Chrome, but here is the installation page



Improvements have also been made to search within Messages. Whenever you search for 
something, results are now divided into categories like people, keywords, photos, and 
links, making them easier to find. There's also a one-time passcode cleanup feature that 
automatically deletes one-time passcodes through Autofill—which helps clean up your list 
of conversations. The company is also making a big push for Stickers. Any stickers you 
create with iOS or iPadOS (including Live Stickers made using Live Photos) are now 
accessible on your Mac too. 

More with Messages
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Regular users of Apple's Photos app will be 
undoubtedly familiar with the People album, 
which tries to identify faces in your pictures so 
that you can label people with their proper 
names and use that label as an organizing 
element in your library or as a discoverable tag. 

In addition to people, the ‌‌Photos ‌‌ app in ‌macOS 
Sonoma‌ can recognize cats and dogs, so you 
can have your pets automatically sorted into 
albums. Accordingly, the People album has 
been renamed the "People & Pets" album. To 
manually assign your furry friends, type "pets" 
into the search field in your library, and you can 
go about identifying any unnamed pets. 

Photos: People & Pets
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Auto-Hide Menu Bar Options
In System Settings -> Control 
Center, there are new options to 
control when the menu bar 
automatically hides. 

Scroll down to the "Menu Bar 
Only" section and click the 
dropdown next to Automatically 
hide and show the menu bar, and 
you'll be able to choose from 
Always, On Desktop Only, On Full 
Screen Only, and Never. 
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In ‌macOS Sonoma ‌, the Weather app has 
received an overhaul, and now includes 
new features like the ability to view the 
previous day's weather, and a new moon 
module that tells you the phases of the 
moon. 

In addition to the ability to view 
temperature in Celsius and Fahrenheit, you 
can also now change the unit 
measurements for wind speed, 
precipitation, pressure, and distance: You 
can find these options in Weather -> 
Settings, under the Units section.

Weather Units
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Weather Settings
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Reminder Grocery Lists
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Apple has added a handy little list function to the 
Reminders app (like in iOS 17) to help you when 
you're out to pick up some groceries. When you 
create a list with the new "Groceries" list type 
(named "Shopping" outside the U.S), you can input 
various foods and sundries and have them 
organized automatically by category. The 
organization makes it easier to find what you need 
when you're at the grocery store, or out shopping. 

The available category types in Reminders include 
Produce, Breads & Cereals, Frozen Foods, Snacks & 
Candy, Meat, Dairy, Eggs & Cheese, Bakery, Baking 
Items, Household Items, Personal Care & Health, 
and Wine, Beer & Spirits.



The Reminders app also features 
a new scrollable Column view, 
making it easy to visualize your 
tasks. 

You can find it in the Reminders 
menu bar, under View -> as 
Columns. 

Each reminder can be set as list 
or column individually, does not 
apply to all! 

Reminder List Column View
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In macOS on machines with Apple 
silicon, you can just say "‌Siri‌" to 
activate ‌‌Siri‌‌, dropping the "Hey" that's 
been used as a wake word for years. 
‌‌Siri‌‌ will activate when you say the ‌‌Siri‌‌ 
word, so you can speak more 
naturally. 

If the change is causing you to 
unintentionally wake ‌Siri‌, you can 
revert it by going to System Settings 
-> ‌Siri‌ & Spotlight, then select Listen 
for -> Hey ‌Siri‌. 

Hey Siri
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Share an AirTag
The Find My app now includes 
the ability to share ‌Find My‌ 
accessories with multiple 
people. Up to five other people 
can share an AirTag or ‌Find My‌ 
network accessory. Simply 
select the ‌AirTag ‌, then click 
Add Person under "Share This 
‌AirTag ‌" to get started. 

Everyone in the sharing group 
is able to see the item's 
location, get directions to the 
item, and play a sound to help 
pinpoint a shared item's 
location when nearby. 
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You can now set your preferred text 
size on a per-app basis, thanks to 
Sonoma's expanded Accessibility 
settings. 

Go to System Settings -> Accessibility 
-> Display, then simply choose the app 
you want to customize text size for and 
make your point selection. 

As of today, you can only set custom 
font sizes for 5 native Apple Apps: 
Calendar, Finder, Mail, Messages and 
Notes. 

Customize Text Size Per App

2024 CLASSES
macOS Sonoma



 Identify Mail Attachment Downloads
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When you download an 
email attachment from Mail 
and view it in Finder, the file 
includes a new mail symbol 
next to it to let you know it's 
an email attachment. 

If you right-click the 
attachment, there's even a 
"Reply to [name of sender]" 
option in the contextual 
menu that when selected 
will open the Mail compose 
window, ready for you to 
type up your reply message.

I could not get this to work but here is what it looks like when it does!



Visual Look Up in ‌Photos ‌ has 
been vastly improved, so you can 
now find similar recipes from 
photos of food, map routes to 
stores identified in photos, and 
identify the meaning of signs and 
symbols on things like laundry 
tags. 

You can also find out information 
about things that appear in 
paused video frames.

Visual Look Up Enhancements
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In System Settings, a new Privacy & 
Security -> Calendar setting allows 
you to give third-party apps write-
only access to your calendars. 

Selecting this means apps are limited 
to writing new events to your 
calendars, without being able to see 
your information.

Add-Only Calendar Access
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Sensitive Content Warnings
With Sensitive Content Warnings enabled in 
‌iOS 17 ‌, incoming files, videos, and images 
are scanned on-device and blocked if they 
contain nudity. The opt-in blurring can be 
applied to images in Messages, AirDrop, 
Contact Posters for the Phone app, 
‌FaceTime‌ messages, and third-party apps. 

Note that this is separate from the 
Communication Safety features the Apple 
has implemented for children, and is 
designed for people of all ages. You can 
enable Sensitive Content Warnings by going 
to System Settings -> Privacy & Security -> 
Sensitive Content Warning and turning on 
the requisite toggle.
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These have been the 50 new 
features introduced with macOS 

Sonoma. 
Hope you enjoyed the 

information and presentation!

Questions? Comments? Observations?

2024 CLASSES
macOS Sonoma



macOS Sonoma

Instructor: Jeff Bohr, Naples Mac Help 

2024 CLASSES




